Bots are intermittently timing out to respond
Incident Report for Ultimate AI's System Uptime
Postmortem

Following a global incident in OpenAI Azure manifesting as timeouts for all calls requiring generative capabilities, all of our bots were timing out intermittently. This resulted in degraded performance across all of our customers, including bots that do not rely on such capabilities. As soon as OpenAI had fixed the incident on their end, our bots resumed to full operation. A small subset of bots participating in the zero shot experiment continued to experience issues thereafter, and so the feature had to be disabled for them.

Through this incident we have discovered an unwanted resource dependency between bots using LLM capabilities and bots that do not use it, a dependency which should not have been there. As per further investigation, this dependency was introduced recently by zero shot functionality. We are exploring a range of short to long term solutions to reach full isolation for similar future cases.

Posted Jul 16, 2024 - 16:56 CEST

Resolved
This incident has been resolved.
Posted Jul 13, 2024 - 14:57 CEST
Monitoring
Following Azure recovery, our bots are now back to full functionality.
We continue to monitor.
Posted Jul 13, 2024 - 11:23 CEST
Update
Azure OpenAI have implement a fix.
We are looking into mitigating lingering impact on bots that do no rely on generative functionalities.
Posted Jul 13, 2024 - 11:14 CEST
Update
Azure OpenAI are still working on fix.
https://azure.status.microsoft/en-us/status
Posted Jul 13, 2024 - 08:39 CEST
Identified
We have narrowed down the issue on the on Azure OpenAI. They have created an incident and are investigating.
https://azure.status.microsoft/en-us/status
Posted Jul 13, 2024 - 05:02 CEST
Update
We are continuing to investigate this issue.
Posted Jul 13, 2024 - 04:24 CEST
Investigating
We have identified bots are too slow to respond
Posted Jul 13, 2024 - 03:15 CEST
This incident affected: Public API and Chat integrations (Sunshine, LiveChat.com CRM Integration, Zendesk Chat, Salesforce, Freshchat, Zendesk Support Automation, Giosg Automation).